Se trata una versión que soluciona errores detectados en la serie 3.x de Joomla.

Se solucionan bugs relacionados con la gestión de sesiones en 3.4.7. Se abordan y corrigen problemas con la creación de contenidos tras a 3.4.7, un error con la conexión a la base de datos y problemas de navegación por el backend, el uso de filtros y la paginación.

Descargas:
Instalación nueva de 3.4.8: (paquete completo en inglés)
https://github.com/joomla/joomla-cms/releases/download/3.4.8/Joomla_3.4.8-Stable-Full_Package.zip

Paquete de Actualización a 3.4.8: (paquete de actualización en inglés)
https://github.com/joomla/joomla-cms/releases/tag/3.4.8

para Joomla .x y 2.5.x
Si todavía trabajas con Joomla .x (EOL) o 2.5.x tendrás que plantearte parchear por tu instalación de contra esta vulnerabilidad grave con los siguientes parches:

https://docs.joomla.org/Security_hotfixes_for_Joomla_EOL_versions